Announcement

Collapse
No announcement yet.

login page looks good but on server it dosnt show pictures

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • login page looks good but on server it dosnt show pictures

    hi when i open my html file on my desktop the login page looks good, but when i open it in the server, it dosnt show my pictures and also the login button dosnt work.. why is this happening... i am also using node.js

    1st picture how it looking when opening in from my server
    2nd picture is how it is supose to look
    Attached Files

  • #2
    You are still on localhost, right? Are the images reachable (access)? Please provide a bit more information so that we can help you.
    Suchmaschinenoptimierung, Templating & Webentwicklung Blog
    Produkt Tests & Geschenkideen

    Comment


    • #3
      Originally posted by dodlhuat View Post
      You are still on localhost, right? Are the images reachable (access)? Please provide a bit more information so that we can help you.
      Yes. If you could either post your code or provide a link to your site, that would help us give better answers.

      That being said, it sounds like you might have an issue with relative paths. If you have absolute paths (something like
      HTML Code:
      <img src="C:\Users\soupi\website\background_image.jpg">
      ) then once you put the files on your server it won't be able to get to that image anymore. If your image is in the same folder on your server as login.html you should just use
      HTML Code:
      <img src="background_image.jpg">
      or whatever the path is - but the point is you assume the starting point for your path is the location of login.html (and make sure you are using forward slashes '/' instead of backslashes '\' in the path!) The same is true if you are using CSS to set your background image instead.

      I apologize if this is all stuff you already knew, but it's my best guess at the moment without knowing more about the problem.

      EDIT: Your problem with the login button no longer working may have the same cause - the path to a script or CSS file needs to be updated.
      Last edited by jansennerd10; 06-07-2016, 01:01 AM.

      Comment

      Working...
      X