Announcement

Collapse
No announcement yet.

PHP upgrade causing session errors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP upgrade causing session errors

    Hi guys,
    I have a dedicated Linux server and have just updated the PHP to 5.3.6, Everything went without problems except when accessing more than 1 site that has a temporary URL e.g 172.11.11.11/~username
    I keep getting the following errors when I open a second or more sites using the temp URL -

    Warning: session_start() [function.session-start]: open(/tmp/sess_c1fded4011824be13e39f14e4c41c572, O_RDWR) failed: Permission denied...

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent...

    Warning: Unknown: open(/tmp/sess_c1fded4011824be13e39f14e4c41c572, O_RDWR) failed: Permission denied.....

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

    I thought it was a session save path issue, it's set to /tmp which does exist.
    Session auto start is set to 0, I tried to change it to 1 and it didn't seem to save this setting.

    Any ideas?
    Thanks

  • #2
    settings

    i think some problem in settings please check once

    Comment

    Working...
    X