Announcement

Collapse
No announcement yet.

Serving Content

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Serving Content

    Hello all,

    I run Windows Server 2003 behind a router. It took me a while, but once I learned that ISP's like to block port 80, I was able to configure IIS and see my content from the Web. Wow, what a big deal that was for me! Whooo hooo!

    One question here on the fly: Is there any way to legally get the ISP to unblock the port?

    Alright, so I had been thinking about trying out Apache on linux for a long time. So, within the past few days, I gave THAT a shot too. Ok, so what I did was, I shut down my Windows Server 2003 and Installed Ubuntu 12.04 desktop on completely different hardware. Then I got Apache up and running on it. Then I proceeded to configure /etc/apace2/ports.conf through the terminal. I do not understand why I cannot see my content from the Web.

    I kept my router settings the same. All I did was give the Ubuntu Server the same settings that Windows Server 2003 was running.

    Does anyone have any ideas as to why I cannot see my content outside my local network?


    Thanks for reading my post

  • #2
    Did you give your linux install the same ip address? or are you getting the IP from DHCP from your router?
    Have a Script or Snippet you want to share?

    WWW Standards: HTML 4.01,
    HTML 5, CSS2.1, CSS3, XHTML 1.0
    PHP Standards: PHP Standards

    Comment


    • #3
      Hello scout,

      Yup! I can't remember the exact method that I used. I think there was a network app with gui. Anyway, I distinctly remember changing the IP config from Auto to Manual and setting the IP address for the server. I've since uninstalled Ubuntu, and Installed Fedora. The worst part is: Now, I am running XP Pro with WampServer. LOL! I am just trying to get some apache, mysql, php under my belt. I am having a hell of a time! But, I didn't get to where I am with html, css, javascript, and asp on IIS 6.0 Server 2003 over night either so.... just gotta keep working at it.


      Ummm... please do not mark this as resolved. I'll reinstall Ubuntu and get back here in a couple days. I will not be satisfied until I can run apache in Windows, Fedora, AND Ubuntu.


      Thanks for your response, and if you have any other ideas pleas let me know.


      I have trouble because I am used to being spoiled with the administration snapins that Microsoft uses. I don't even go to cmd prompt all that often in Windows. So when I gotta go to a terminal on a foreign language and manualy edit config files on a filesytem that is also foreign... shweeeew! I am lucky that I've gotten as far as I have. I unistalled Ubuntu, not because I wanted to give up trying to administer apache, but because of the uncustomizeable desktop. If I could have undocked the left side and ran it across the bottom of the screen, I'd probably still be in Ubuntu viewing php pages from the web. lol ... could just be wishful thinking though

      Comment


      • #4
        Back up and running ... yeah, almost

        Hello all,

        Ok, so Ubuntu desktop 12.04 is running. I got apache 2.2.22, mysql 5.5.28, php 5.3.10-1ubuntu3.4.

        I got localhost: It works!
        I created a folder in /var/www after using gksudo nautilus /var to set permissions properly and wrote a very basic .php file to view from FireFox.
        I have phpmyadmin installed and working
        I have info.php that I can view
        ... And finally, I have Webmin intalled and also working

        Here is what I cannot do:

        Access the defaut page (It works!) from another PC on my local network by typing in the 192.168 ... etc. etc I get the: Internet Explorer cannot display the webpage


        Also, I have my router configured to redirect a port. So I type my public IP address with the specified port number in the address bar of Internet Explorer from a different machine on my network. I should get redirected to the ip address of the Ubuntu computer running apache. External port is changed, internal port stays at 80. So when I type in: public.ip.address.15:81 it should direct the request to 192.168 etc. etc the ip address for the ubuntu pc on port 80 which is what the server address is set to. ... Well, it give me the same: Internet Explorer cannot display webpage

        Ok,ok,ok,... so, first thing is first. What do I have to change just to see the "It Works!" page from my local network?


        ... THEN maybe I'll try to view the page from the public ip



        I truly appreciate the help. Thanks in advance!

        Comment


        • #5
          Well, well, well, ... DONK! lol Yeah, I forgot to mention that I am running FireStarter. I disabled the firewall temporarily and voila! I just have to learn how to configure the firewall. smh...smh...smh lol Cheers, everybody!

          Comment

          Working...
          X